Look Up Version Information

Overview

You can use the NGINX Controller command-line interface, web interface, and API to look up the version information for NGINX Controller. The NGINX Controller API also returns version information for the NGINX Controller components.

Use the Command-Line to Look Up Version Info

Use the helper.sh script found at /opt/nginx-controller/ to view the version details for NGINX Controller.

  1. Open a secure shell (SSH) connection to the NGINX Controller host and log in.

  2. To view the version details, run the following command:

    /opt/nginx-controller/helper.sh version

    The output looks like the following:

    Installed version: 3.4.0
    Running version: 3.4.0
    

Use the Web Interface to Look Up Version Info

  1. Open the NGINX Controller user interface and log in.

  2. Select the NGINX Controller menu icon, then select Platform.

  3. On the Platform menu, select Information. The Platform Overview page displays the NGINX Controller build number and version.

Use the NGINX Controller API to Look Up Version Info

Note:
See the NGINX Controller API reference guide for complete API and endpoint documentation.

To look up the version information for NGINX Controller and its components by using the API:

  1. Log in to the NGINX Controller by sending a POST request to the Login endpoint. For example:

    curl -c cookie.txt -k -X POST --url 'https://198.51.100.10/api/v1/platform/login' --header 'Content-Type: application/json' --data '{"credentials": {"type": "BASIC","username": "[email protected]","password": "Towel$123"}}'
    
  2. Send a GET request to the Global Settings endpoint:

    curl -b cookie.txt -c cookie.txt -X GET --url 'https://<Controller-FQDN>/api/v1/platform/global'
    

    The JSON response looks like the following:

    {
      "metadata": {...},
      "desiredState": {...},
      "currentStatus": {
        "agentSettings": {...},
        "platformSettings": {...},
        "platformVersion": {
              "buildNumber": "1663923",
              "components": [
                {
                    "application": "apigw",
                    "version": "3.4.0"
                  },
                  {
                    "application": "catalogs",
                    "version": "0.96.1"
                  },
                  {...}
              ],
              "version": "3.4.0"
            }
        },
        "state": {...}
    }
    

This documentation applies to the following versions of NGINX Controller Documentation:
3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8, 3.9 and 3.10.